DEĞİŞKEN UZUNLUKLU ALT AĞ MASKESİ- VLSM (VERIABLE LENGHT SUBNET MASK)

alt_ağSabit alt ağa ayırma işlemi yapılırken (basic subneting) her bir alt ağda  kullanıcı sayısı aynı olur. Ancak gerçek hayatta genellikle alt ağlarda kullanıcı (host) sayısı eşit olmaz. Geleneksel alt ağa ayırma işleminde, en geniş LAN'ın gereksinimlerini karşılayacak şekilde ayırırız. Fakat adres alanını yeterli sayıda alt ağa böldüğümüz zaman kullanmadığımız fazladan host adreslerini boşa harcamış oluruz.

Örneğin bir WAN bağlantısı için 2 host adresi kullanılır. Mesela 192.168.1.0/24 ağını 4’e böldüğümüzü düşünürsek 4=2^a formülünden (a: ödünç alınan host bitleri) host bitlerinden 2 biti ödünç almamız gerekir. Yani  her bir alt ağda (2^6)-2=60 host adresi olacaktır. (Burada 6 kalan host bitlerini ifade ediyor) WAN bağlantısı için sadece 2 host kullanılır. Burada geriye kalan 58 host boşa harcanır.

Bu durumu önlemek için değişken uzunlukta alt ağ maskesi kullanılabilir. (VLSM= Variable Lenght Subnet Mask) VLSM kullanırken, alt ağ maskesi belirli bir alt ağ için kaç adet host biti ödünç alındığına bağlı olarak değişecektir. VLSM kullanılırken ağ, ilk önce alt ağlara ayrılır, ardından alt ağlar tekrardan alt ağa ayrılır. Bu işlem çeşitli boyutlarda alt ağlar oluşturmak için birden fazla tekrarlanabilir. LAN ve WAN segmentleri, VLSM kullanılarak ip adresleri boşa harcanmadan adreslenebilir.

Önceki alt ağa ayırma örneklerinin tümünde, her alt ağ için subnet mask değeri aynıydı. Bu, her bir alt ağın aynı sayıda kullanılabilir host adresine sahip olduğu anlamına geliyordu. VLSM için kullanıcı sayısı ve ödünç alınan host bitleri sayısı her bir ağ için değişeceğinden, ilgili ağın subnet mask değeri de değişecektir. Subnet mask değeri network bitlerinin tamamı 1, host bitlerinin de tamamı 0 yapılarak hesaplanır.

Yukarıdaki örnek topolojinin çözümü için aşağıdaki videodan faydalanabilirsiniz.

AĞI ALT AĞ SEGMENTLERİNE AYIRMA -1 (BASIC SUBNETING)

routerlarBir kuruluştaki tüm cihazlara ip adresi ve bununla eşleşen bir ağ kimliği ataması düz ağ tasarımı olarak bilinir.  Düz ağ tasarımını büyük işletmelerde kullanmak oldukça zordur. Mesela  Ethernet LAN üzerinde bir cihazın dinamik Host Yapılandırma Protolüne (DHCP) ulaşması için ağa bir genel yayın paketi  (broadcast) göndermesi gerekir. Bu durum ağ traifiğinin yavaşlamasına neden olur ve büyük networklerde ciddi sorunlara neden olur. Bu nedenle büyük ağları daha küçük alt ağlar şeklinde segmentlere ayırmak gerekir.

Ağ yöneticisi ağ cihazlarını alt ağlara guruplarken;

  • Coğrafi bir konuma (binanın 2. Katı gibi),
  • Kurumsal birimlere (satış departmanı),
  • Cihaz türüne göre (WAN,sunucular,yazıcılar) guruplayabilir.

Bir networkü alt ağlara bölerken farklı alt ağdaki cihazların haberleşebilmesi için yönlendirici (router) gereklidir. Ağ üzerindeki cihazlar, LANlarına bağlı yönlendirici arayüzünü varsayılan ağ geçidi (default gateway) olarak kullanır. Router bir paketin yerel ağa mı uzak ağa mı gideceğini belirlerken alt ağ maskesini (subnet mask) kullanır. Aynı ağda bulunan cihazların subnet mask değeri aynı olur.

Network’ü bölerken her alt ağda en az kaç kullanıcı olacağını belirleyip optimum bir ip bloğu seçerek bölmek gerekir. Özel adres bloğunu seçerken temel alınması gereken 2 etken vardır. Bunlardan birincisi gerekli alt ağ sayısı ikincisi ise alt ağ başına gerekli maksimum kullanıcı (host) sayısıdır.

Bir networkün kaç alt ağa bölündüğü 2^a formülü bulunabilir. Burada a değeri ödünç host bitlerini temsil eder.  Bir ağdaki kullanıcı sayısı da 2^n-2  formülü ile hesaplanır. Burada n ilgili networkün host bitlerini temsil eder. Ayrıca network ve genel yayın (broadcast) adresini cihazlara veremeyiz bu nedenle bu iki adresi de çıkardık.  Aşağıda bir networkte ilk kullanılabilir ip, son kullanılabilir ip, broadcast address ve subnet mask değerlerinin nasıl hesaplanacağı kısaca açıklanmıştır:

Network adresi: Host bitlerinin tamamı 0 yapılarak bulunur.

İlk kullanılabilir ip adresi: network adresinin 1 fazlasıdır.

Broadcast adres: Host bitlerinin tamamı 1 yapılarak hesaplanır.

Son kullanılabilir ip adresi: Broadcast adresinden (genel yayın adresi) 1 eksiktir.

Subnet Mask: Network bitlerinin tamamı 1, host bitlerinin tamamı 0 yapılarak hesaplanır.

Örneğin;

192.168.1.0/24 ağı 24 network ve 8 host bitlerinden oluşur. Bu ağı 2 alt ağa bölecek olursak:

network bitleri

Böyle bir networkte host bitlerinden 1 bit ödünç alınırsa (192.168.1.0/25) alt ağ sayısı 2^1=2 olarak bulur. Her bir alt ağda bulunan kullanıcı sayısı da 2^7-2=126 olarak bulunur. Bu ağın;

1.Alt Ağı İçin:

Ağ Adresi (Network adresi);192.168.1.0

subnet mask değeri ; 11111111 . 11111111 . 11111111 . 1/0000000 yani 255 .255 .255.128 olur.

İlk kullanılabilir ip adresi; 192.168.1.1

Son kullanılabilir ip adresi ; 192.168.1.126 olur.

Broadcast adresi; 192.168.1.0/1111111 yani 192.168.1.127 olur.

2.Alt Ağı İçin

Ağ Adresi (Network adresi);192.168.1.128

subnet mask değeri ; 11111111 . 11111111 . 11111111 . 1/0000000 yani 255 .255 .255.128 olur.

İlk kullanılabilir ip adresi; 192.168.1.129

Son kullanılabilir ip adresi ; 192.168.1.254 olur.

Broadcast adresi; 192.168.1.0/1111111 yani 192.168.1.255 olur.

resim-2

Yukarıdaki şekildeki yönlendiricinin fastethernet arabirimlerine ip adresi aşağıdaki komutlarla verilir. Router arabirimine verilen ip adresi ilgili ağın varsayılan ağ geçidi (default gateway) dir.

Router0(config)#interface fastethernet 0/0
Router0(config-if)#ip address 192.168.1.1 255.255.255.128
Router0(config-if)#no shut
Router0(config-if)#exit
Router0(config)#interface fastethernet 0/1
Router0(config-if)#ip address 192.168.1.129 255.255.255.128
Router0(config-if)#no shut
Router0(config-if)#exit

Daha geniş örnek çözümleri için aşağıdaki videodan faydalanabilirsiniz.

Ağ Cihazlarını Yapılandırma-2 yönlendiricinin (router) yapılandırılması

YÖNLENDİRİCİNİN İLK AYARLARINI YAPILANDIRMA

R1

Yönlendiricide (router’da) ilk ayarlar yapılandırırken, anahtar yapılandırmaya benzer şekilde aşağıdaki komutlar CLI’dan girilir.
hostname global yapılandırma komutunu kullanarak cihaza yeni bir isim verin.

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#

Yönlendirici parolaları (konsol,enable secret,telnet parolaları) yapılandırın.
enable secret komutunu kullanarak ayrıcalıklı EXEC modu erişimi güvenceye alın.

R1(config)#enable secret cisco

Ayrıcalıklı exec modu için “cisco” şeklinde bir parola vermiş olduk.
Konsol portunda login komutunu ve parolayı ayarlamak için password komutunu kullanarak EXEC modu erişimini güvenceye alın. Konsol parolası “R1>enable” komutundan sonra istenilecek paroladır.

R1(config)#line console 0
R1(config-line)#password cetin //konsol şifresi cetin
R1(config-line)#login
R1(config-line)#exit

Parolaların yapılandırma dosyasında düz metin olarak görüntülenmesini önlemek için service password-encryption global yapılandırma komutunu kullanılarak verdiğiniz parolaları şifreleyin.

R1(config)#service password-encryption

banner motd global yapılandırma komutu kullanılarak yasal bildirim için açıklamalar yazılır. CLI’de Türkçe karakter kullanmamaya dikkat edin. Zaten muhtemelen program Türkçe karakter yazımını Kabul etmeyecektir.

R1(config)#banner motd “Yonetici Izni  Olmadan Erisim Yasaktir ”

copy run start komutu kullanarak yapılandırma ayarları başlangıç yapılandırma dosyasına (startup-config) kaydedin.

R1#copy running-config startup-config

Telnet bağlantısı için portlara parola atayarak sanal arayüz yapılandırması güvence altına alın.

R1(config)#line vty 0 4  //0 ile 4 arasındaki port erişimini sınırlandırmış olduk
R1(config-line)#password azizoglu //telnet bağlantısı için parolamız azizoglu
R1(config-line)#login
R1(config-line)#exit
R1(config)#exit

show run komutunu kullanarak yapılandırmaları doğrulayın.

R1#show running-config  //veya
R1#sh run //şeklinde komutlar kısaltılarak yazılabilir.

YÖNLENDİRİCİ ARABİRİMİNİ YAPILANDIRMA (ROUTER INTERFACE CONFIGURATION)

Yönlendiricilerin ulaşılabilir olması için, yönlendirici arayüzüne ip adresi vererek yapılandırılmalıdır. Belirli bir arayüzü etkinleştirmek için interface arabirim tipi-ve-numara global yapılandırma modu komutunu kullanarak arayüz yapılandırma moduna girin.
Cisco yönlendiricilerinde farklı türde arayüzler bulunmaktadır. Cisco 1941 yönlendiricisi iki Gigabit Ethernet arayüzüyle ve iki arayüzden oluşan seri WAN arayüz kartı (WIC) bulundurur. Arayüzler aşağıdaki gibi adlandırılmıştır:

  • Gigabit Ethernet 0/0 (G0/0)
  • Gigabit Ethernet 0/1 (G0/1)
  • Serial 0/0/0 (S0/0/0)
  • Serial 0/0/1 (S0/0/1)

Cisco 1841 yönlendiricilerinde ise Gigabit Ethernet yerine Fast Ethernet portları bulunmaktadır.
Yönlendirici arayüzünü etkinleştirmek için aşağıdaki komutlar kullanılır:

R1(config)#interface fastethernet0/0  //bu komutla ilgili arabirime girilir.
R1(config-if)#ip address ilgili-arabirime-verilecek-ip-adresi subnet-mask

Yönlendirici arabirimlerine network adresi verilmez.Arabirimlere host adresi verilmelidir.
Subnet mask
İlgili ağın subnet maskı hesaplanırken ağın network bitlerinin tamamı 1, host bitlerinin tamamı ise 0 yapılarak hesaplanır. Mesala 192.168.1.0/24 ağının subnet maskını hesaplayalım:
192.168.1./00000000
11000000.10101000.00000001./00000000
11111111.11111111.11111111./00000000

192.168.1.0/24 ağının subnet  maskı 255.255.255.0 şeklinde olur.
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown //komutu ile ilgili arabirim portu etkinlerştirilir.

Arayüz yapılandırılmasını doğrulamak için ayrıcalıklı exec modunda show ip interface brief komutu kullanılabilir. Bu komut sonucunda görüntülenen çıktı tüm arayüzleri, IP adreslerini ve mevcut durumlarını görüntüler.

R1#show ip interface brief

 

Aynı işlemleri topolojide bulunan tüm yönlendirici (router) cihazları için yapın. Son olarak ilgili ağın yapılandırmasını test etmek için cihazlar arası ping çekin. Sadece yönlendiricinin bağlı olduğu ağa ping paketinin başarılı bir şekilde iletildiğini göreceksiniz. Bir topolojide yönlendiriciye bağlı olmayan ağa bağlanabilmek için static veya dinamik routing (Eigrp, Ospf, Rip Version1, Rip Version2) protokollerinden birinin tanımlanmış olması gerekmektedir. Yönlendiricinin bağlı olduğu ağları görüntülemek için:

R1#show ip route

komutu kullanılır. Yönlendirici arabirim yapılandırması hakkında daha ayrıntılı bilgi için aşağıdaki video'dan faydalanabilirsiniz:

Ağ Cihazlarını Yapılandırma-1 (Anahtar ve Yönlendiriciye İsim ve Parola Verme)

CLI (Command Line Interface) ortamına erişmek için kullanılan en yaygın yöntemler konsol portu, telnet veya ssh’dır.

Konsol Portu

Konsol portu kullanarak ilgili ağda, ağ hizmeti yapılandırılmamış olsa dahi (örneğin ağ cihazı ilk kez yapılandırılırken) cihaza erişim sağlanabilmekte ve cihaz yapılandırılabilmektedir. İlk yapılandırma sırasında, terminal emülasyon yazılımını (hyperterminal, putty vs.) çalıştıran bir bilgisayar, özel bir kablo (console kablosu) kullanılarak cihazın konsol portuna bağlanır. Anahtar (switch) veya yönlendiricinin (router) ayarlanmasına yönelik yapılandırma komutları bağlı bilgisayardan girilebilir. Konsol portu ayrıca ağ cihazları hata verdiğinde ve Cisco IOS cihazına uzaktan erişimin sağlanamadığı durumlarda kullanılabilir.
console2
Birçok IOS cihazında, konsol erişimi varsayılan olarak şifresizdir. Fakat cihaza yetkisiz erişimi önlemek için konsol, parolalarla yapılandırılmalıdır. Bir anahtarın (Switch) konsol erişimine şu komutlarla parola verilebilir:

Switch#configure terminal        //ayrıcalıklı exec mod (privileged mode)
Switch(config)#line console 0  //global mod
Switch(config-line)#password cetin
Switch(config-line)#login

Yönlendirici (router) cihazının konsol erişimini sınırlandırmak aşağıdaki komutlarda görüldüğü gibi anahtar yapılandırmasıyla aynıdır.

Router>enable Router#configure terminal        //ayrıcalıklı exec mod (privileged mode) Router(config)#line console 0  //global mod Router(config-line)#password cetin Router(config-line)#login Switch>enable

Konsol parolasını cetin olarak vermiş olduk. Komutların bir kısmını yazıp tab tuşuna basarak tamamlayabiliyoruz.

Telnet

Telnet, terminal emülasyon programları kullanılarak sanal arayüz yoluyla ağ cihazlarına uzaktan erişmek ve yapılandırmaktır. Telnet bağlantısının yapılabilmesi için ağ cihazı, IPv4 gibi bir İnternet adresiyle yapılandırılmış en az bir etkin arayüze sahip olmalıdır. Cihazın telnet erişimini sınırlandırmak için aşağıdaki gibi parola verilebilir.

Switch(config)#line vty 0 15
Switch(config-line)#password azizoglu
Switch(config-line)#login

Burada telnet parolamız azizogludur.

Ayrıcalıklı Exec Modunu Sınırlandırma

Kullanıcı exec modu 2 farklı şekilde sınırlandırılabilir. Birinci yöntem:

Switch(config)#enable secret cisco

İkinci yöntem:

Switch(config)#enable password cisco2

Cihazlara isim verme

Ağ cihazları yapılandırılırken isimleri aşağıdaki gibi “hostname” komutu ile değiştirilebilmektedir.

Switch(config)#hostname Cetin
Cetin(config)#

Anahtar (Switch) yapılandırmasının ayrıntıları için aşağıdaki videodan faydalanabilirsiniz.